Errors during npm install

I just cloned the CoreUI React Admin Template. When I run npm install I am getting the following warnings plus errors:

$ npm install
npm WARN ERESOLVE overriding peer dependency
npm WARN Found: react@17.0.1
npm WARN node_modules/react
npm WARN   react@"^17.0.1" from the root project
npm WARN   9 more (@coreui/icons-react, @coreui/react, react-dom, ...)
npm WARN 
npm WARN Could not resolve dependency:
npm WARN peer react@"0.13.x || 0.14.x || ^15.0.0-0 || ^16.0.0-0" from enzyme-adapter-utils@1.14.0
npm WARN node_modules/enzyme-adapter-utils
npm WARN   enzyme-adapter-utils@"^1.13.1" from @wojtekmaj/enzyme-adapter-react-17@0.3.2
npm WARN   node_modules/@wojtekmaj/enzyme-adapter-react-17
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! Found: react@17.0.1
npm ERR! node_modules/react
npm ERR!   react@"^17.0.1" from the root project
npm ERR!   peer react@"^17.0.1" from @coreui/icons-react@1.1.0
npm ERR!   node_modules/@coreui/icons-react
npm ERR!     @coreui/icons-react@"^1.0.2" from the root project
npm ERR!     @coreui/icons-react@"^1.1.0" from @coreui/react@3.4.6
npm ERR!     node_modules/@coreui/react
npm ERR!       @coreui/react@"^3.4.0" from the root project
npm ERR!   8 more (@coreui/react, react-dom, react-router-dom, ...)
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer react@"^0.14 || ^15.0.0 || ^16.0.0-alpha" from airbnb-prop-types@2.16.0
npm ERR! node_modules/enzyme-adapter-utils/node_modules/airbnb-prop-types
npm ERR!   airbnb-prop-types@"^2.16.0" from enzyme-adapter-utils@1.14.0
npm ERR!   node_modules/enzyme-adapter-utils
npm ERR!     enzyme-adapter-utils@"^1.13.1" from @wojtekmaj/enzyme-adapter-react-17@0.3.2
npm ERR!     node_modules/@wojtekmaj/enzyme-adapter-react-17
npm ERR!       @wojtekmaj/enzyme-adapter-react-17@"^0.3.2" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.

Any idea what’s going on and how to fix it?

Thanks in advance.

-Mark

I Found a fix looking around at the npm libraries.

If you look at:

You will see that npm install has to be run with “–legacy-peer-deps” in order to work.

If you get problems with node-sass, update the version to 5.0.0. 4.x.x does not work with latest node version.

Best regards,
Jørgen S.

Thanks neno91! I was reluctant to just use the '--legacy-peer-deps' option that was suggested in the error message, but that note in the doc for enzyme-adapter-react-17 makes it clear that it is ok.

1 Like

You’re welcome :grinning: