Support for Nuxt.js (vue.defineComponent is not a function)

CoreUI Vue 4.x uses Vue 3.x, and vue.defineComponent is part of the Vue 3 API.

If you’re using Nuxt.js 2.x (Vue 2.x) you can’t use CoreUI Vue 4.x. Install 3.x instead.